Fehlermeldung beim Update

Aktuelle Version: 1.0.2
Veröffentlicht: 25.04.2010
Helmut
Mitglied / Member
Mitglied / Member
Beiträge: 6
Registriert: So 2. Mai 2010, 19:35

Fehlermeldung beim Update

Beitrag von Helmut » So 2. Mai 2010, 20:12

Hallo,

ich habe gerade das Update von Version 1.0.1 auf 1.0.2 gestartet, aber das Update bleibt nach der Aktualisierung der Datenbank hängen, siehe Bild.

Bild

Leider konnte ich den Fehler nicht finden, es passiert sowohl beim localhost (xampp) als auch auf dem Server. Kannst du mal das prüfen woran es liegen könnte?

Gruß Helmut

Benutzeravatar
Marc
Administrator
Administrator
Beiträge: 619
Registriert: Di 2. Sep 2008, 23:48
phpbb.com: Marc
Wohnort: Munich

Re: Fehlermeldung beim Update

Beitrag von Marc » So 2. Mai 2010, 20:20

Welchen Browser benutzt du? Die Seite wird mehrfach neu geladen um Timeouts zu entgehen, dabei handelt es sich aber nicht um eine Endlosschleife. Bis jetzt bist du auch der Erste der von diesem Problem berichtet. Wie groß ist dein Forum (Beiträge)?
Bild

Helmut
Mitglied / Member
Mitglied / Member
Beiträge: 6
Registriert: So 2. Mai 2010, 19:35

Re: Fehlermeldung beim Update

Beitrag von Helmut » So 2. Mai 2010, 20:30

Hallo,

ich verwende den Firefox 3.6.3 unter Windows XP. Das Forum hat etwa 16.000 Beiträge, ca. 2300 Themen und ca. 1350 User, also nicht allzu groß. Ob das Update unter dem IE8 durchlaufen würde, habe ich noch nicht getestet.

Gruß Helmut

Benutzeravatar
Marc
Administrator
Administrator
Beiträge: 619
Registriert: Di 2. Sep 2008, 23:48
phpbb.com: Marc
Wohnort: Munich

Re: Fehlermeldung beim Update

Beitrag von Marc » So 2. Mai 2010, 20:55

Hast du Cookies deaktivert oder blockiert? Versuche mal auf den Link "Alle Cookies des Boards löschen" zu klicken und den Installer danach noch einmal auszuführen.
Bild

Helmut
Mitglied / Member
Mitglied / Member
Beiträge: 6
Registriert: So 2. Mai 2010, 19:35

Re: Fehlermeldung beim Update

Beitrag von Helmut » So 2. Mai 2010, 21:05

Hallo,

neee, Cookies sind erlaubt. Ich habe es jetzt so gemacht und nochmal das Update gestartet, aber die Meldung kommt trotzdem noch. Auch den Cache habe ich natürlich geleert gehabt.

Gruß Helmut

Benutzeravatar
Nashra
Mitglied / Member
Mitglied / Member
Beiträge: 15
Registriert: Fr 7. Mai 2010, 12:48
Wohnort: Geldern

Re: Fehlermeldung beim Update

Beitrag von Nashra » Fr 7. Mai 2010, 12:53

Hallo,
wollte heute das Update durchführen und bekomme die selbe Fehlermeldung wie Helmut.
Kann machen was ich will, er bricht ab.

Gruß
Ralf
„Die Menschen müssen lernen wieder zu sehen, was sie anschauen.
Sie müssen ihr Pferd fühlen, um es begreifen zu können.“

Tom Dorrance, 1910 - 2003

Benutzeravatar
Marc
Administrator
Administrator
Beiträge: 619
Registriert: Di 2. Sep 2008, 23:48
phpbb.com: Marc
Wohnort: Munich

Re: Fehlermeldung beim Update

Beitrag von Marc » Fr 7. Mai 2010, 13:41

Ich werde heute mal sehen ob ich das reproduzieren kann.
Bild

Benutzeravatar
Marc
Administrator
Administrator
Beiträge: 619
Registriert: Di 2. Sep 2008, 23:48
phpbb.com: Marc
Wohnort: Munich

Re: Fehlermeldung beim Update

Beitrag von Marc » Fr 7. Mai 2010, 16:22

Gefunden. :D

Das Paket wird heute noch aktualisiert. Ich hatte da noch einen Testcode drinnen, der für jeden Beitrag einen Redirect auslöst, was bei mehr als 20 Beiträgen wohl zu einem Fehler in Firefox führt. ;)
Bild

Benutzeravatar
Nashra
Mitglied / Member
Mitglied / Member
Beiträge: 15
Registriert: Fr 7. Mai 2010, 12:48
Wohnort: Geldern

Re: Fehlermeldung beim Update

Beitrag von Nashra » Fr 7. Mai 2010, 16:58

Marc hat geschrieben:Gefunden. :D

Das Paket wird heute noch aktualisiert. Ich hatte da noch einen Testcode drinnen, der für jeden Beitrag einen Redirect auslöst, was bei mehr als 20 Beiträgen wohl zu einem Fehler in Firefox führt. ;)
fantastisch, manchmal sinds zum Glück nur Kleinigkeiten und Danke für die schnelle Fehlerbehebung :mrgreen:
„Die Menschen müssen lernen wieder zu sehen, was sie anschauen.
Sie müssen ihr Pferd fühlen, um es begreifen zu können.“

Tom Dorrance, 1910 - 2003

Benutzeravatar
Marc
Administrator
Administrator
Beiträge: 619
Registriert: Di 2. Sep 2008, 23:48
phpbb.com: Marc
Wohnort: Munich

Re: Fehlermeldung beim Update

Beitrag von Marc » Fr 7. Mai 2010, 17:38

So, ich hab das Paket aktualisiert.
Folgende Dateien müssen ausgetauscht werden:
  • adm/style/acp_stats_addons.html
  • includes/acp/acp_stats.php
  • includes/stats/stats_basic.php
  • includes/stats/stats_settings.php
  • statistics/includes/functions.php
Und einfach den ganzen install-Ordner noch einmal neu hochladen.
Bild